Raydium 3D Game Engine

Official forum for everything about Raydium, ManiaDrive, MeMak, ...
It is currently Mon Sep 25, 2017 10:31 pm

All times are UTC




Post new topic Reply to topic  [ 5 posts ] 
Author Message
PostPosted: Thu Nov 06, 2008 8:36 am 
Offline

Joined: Thu Nov 06, 2008 8:26 am
Posts: 1
Bonjour,
tout d'abord bravo pour ce moteur fort sympathique.
Je suis sous Leopard, j'ai téléchargé la dernière version du SDK pour MAC (la R759) et je rencontre un problème. Lorsque je lance configure, ça bloque ici :

-ne * Testing OpenGL...
build: failed
You must install opengl-devel package


j'ai cherché le package avec fink mais impossible de le trouver. Je ne suis pas très familier avec l'environement unix et donc je suis un peu perdu. Un peu d'aide serait la bienvenue :wink:

d'avance merci.


Top
 Profile  
 
PostPosted: Thu Nov 06, 2008 12:54 pm 
Offline

Joined: Tue Jul 08, 2008 2:37 am
Posts: 181
Hello webslinger,

welcome to the Raydium forum.

Gladly to see someone trying out the Raydium SDK for Mac OS X! :D
As described in the read me file you have to install Xcode 2.4 or higher and you should be Raydium ready. The configure script does not include support for this target, it is not needed and not really necessary under Mac OS X, since everything related to the Raydium dependencies should be included within the SDK.

You could try the following:
  • Open a terminal.
  • Change directory to the Raydium SDK (e. g. "cd /Library/Raydium").
  • Use the iCompile script to build the samples (e. g. "./iCompile test6.c").

You're pleased to report/give feedback to us. Thank you very much.

Best regards,
st


Last edited by st on Wed Feb 15, 2012 6:42 pm, edited 1 time in total.

Top
 Profile  
 
PostPosted: Thu Jan 01, 2009 9:42 pm 
Offline
User avatar

Joined: Sun Mar 16, 2003 2:53 am
Posts: 2590
Location: gnniiiii (Scrat)
Ouille: we can perhaps add some sort of warning at the beginning of the configure script when we detect a MacOS X platform to avoid such confusions ?

How can we detect this target from the script ?


Top
 Profile  
 
PostPosted: Fri Jan 02, 2009 1:15 pm 
Offline

Joined: Tue Jul 08, 2008 2:37 am
Posts: 181
I'm not ouille, but I want to help here, too. :roll:
Xfennec wrote:
How can we detect this target from the script ?
We could provide some check at the main entry point of the configure script. Either checking if it is not GNU/Linux or if it is Mac OS X. The following example code, inserted on line 245, will do it for the second possibility.
Code:
if [ "`uname`" = "Darwin" ]; then
    exit_if_error 1 "This script does not include support for your target. Please use the iCompile script from the SDK to build the samples (e. g. \"./iCompile test6.c\")."
fi
I can commit the modification, if you agree with this.


Top
 Profile  
 
PostPosted: Fri Jan 02, 2009 9:14 pm 
Offline
User avatar

Joined: Sun Mar 16, 2003 2:53 am
Posts: 2590
Location: gnniiiii (Scrat)
Add an "exit 1" or something and it's OK for me !


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group