Raydium 3D Game Engine
http://memak.raydium.org/

Steering wheel (joystick) problem
http://memak.raydium.org/viewtopic.php?f=10&t=2086
Page 1 of 1

Author:  Omri [ Sat Jan 30, 2010 5:20 pm ]
Post subject:  Steering wheel (joystick) problem

Hello,

I am using linux (ubuntu 8.04), and I have a problem: my USB steering wheel is not recognized in ManiaDrive. I tried the -- joydev option but it didn't work. Also, I'm not sure I'm using it correctly.
Here is the relevant part of the output of dmesg:
Code:
[ 6291.812832] input: GreenAsia Inc.    USB Joystick      as /devices/pci0000:00/0000:00:02.0/usb1/1-2/1-2:1.0/input/input11
[ 6291.844724] input,hidraw0: USB HID v1.10 Joystick [GreenAsia Inc.    USB Joystick     ] on usb-0000:00:02.0-2

Can you please tell me how should I run ManiaDrive to have support for my joystick?

Thanks a lot!

Author:  Xfennec [ Mon Feb 01, 2010 10:15 pm ]
Post subject:  Re: Steering wheel (joystick) problem

Hi,

You said you've tried the --joydev command line switch, but which device have you provided to this switch ?
You should have a look at /dev/input/js* so you could find you game controller and give it the the joydev option.

Another (important !) point is that currently, ManiaDrive does not allows the user to change controls (sadly). So if the mapping of your device is not correct by default (which is very likely), you won't be able to use your controller unless you start modifying the game's source code.

Page 1 of 1 All times are UTC
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/