Raydium 3D Game Engine
http://memak.raydium.org/

Error loading track...
http://memak.raydium.org/viewtopic.php?f=10&t=2292
Page 1 of 1

Author:  slidercrank [ Wed Sep 05, 2012 7:10 am ]
Post subject:  Error loading track...

Whenever I choose "Internet tracks" it's always with the same error message
"Error loading track..". No matter what track I choose (apart from the standard tracks already shipped with the game)
The related log chunk would be:
Raydium: Using repositories to get 'carot.mni' file
Raydium: No valid repository found for this file, aborting.
Raydium: mni_gen: unable to open 'carot.mni'
Raydium: CANNOT GENERATE TRACK FROM MNI FILE 'carot.mni'

$ rpm -qa|grep mania
maniadrive-1.2-32.fc16.8.i686
maniadrive-data-1.2-6.fc15.noarch
maniadrive-music-1.0-5.fc15.noarch

Fedora 16.

Author:  Xfennec [ Wed Sep 05, 2012 8:47 am ]
Post subject:  Re: Error loading track...

Hi,

Thanks for reporting this issue. It seems that something is broken in Fedora's package, since carot.mni is actually available on our repositories, and I've just tested all this with a "vanilla" version of the game, without any trouble.

Looking at the log you've provided, it seems that "R3S" (our included downloading client, sort of) is here, but I can't see it "searching" over our servers. Like if the server list was empty.

The only Fedora I can put my hands on is a F15, so I can't check things by myself, but :
- do you have any ~/.mania_drive/repositories.list file ? if yes, what is its content ?
- do you have any other "repositories.list" file (it may be in /usr/local/share/raydium/rayphp/) ? same question about file's content.

Author:  slidercrank [ Wed Sep 05, 2012 8:15 pm ]
Post subject:  Re: Error loading track...

Thank you for the reply.

The version of Fedora doesn't matter. I remember I was unable to load Internet tracks in the previous versions as well.

I found the file
/usr/share/raydium/rayphp/repositories.list
belonging to the package
raydium-1.2-32.fc16.8.i686

Its content is
$ cat /usr/share/raydium/rayphp/repositories.list
# This file lists data (tri, tga, wav, ogg, ...) repositories.
# Listed servers must run R3S (Raydium Server Side Scripts) files.

# you can only use http and https protocols:
# http://host.tld/path

# main:
http://fastrepo.raydium.org/
http://repository.raydium.org/

# we needs "contrib" servers

I traced a syscall to open this file
$ strace -e trace=open -o mania.log maniadrive-wrapper
$ grep repo mania.log
open("/usr/share/raydium/rayphp/rayphp/repositories.list", O_RDONLY) = -1 ENOENT (No such file or directory)

so the source of the issue was located.
/usr/share/raydium/rayphp/repositories.list (where it's actually located)
/usr/share/raydium/rayphp/rayphp/repositories.list (where the game searches for the file)

I tried to put the file where the game expects it to be to make sure it would work. It worked like a charm.

Now it's time to report fedora maintainers about this issue.

Author:  Xfennec [ Wed Sep 05, 2012 8:21 pm ]
Post subject:  Re: Error loading track...

Well ... All this was quite efficient :)

Page 1 of 1 All times are UTC
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/