Raydium 3D Game Engine
http://memak.raydium.org/

running ManiaDrive on an Intel-Mac?
http://memak.raydium.org/viewtopic.php?f=10&t=534
Page 1 of 2

Author:  basti [ Thu Aug 31, 2006 12:27 pm ]
Post subject:  running ManiaDrive on an Intel-Mac?

Hi,
i love the game, great work!
but is there a possibility to get it work on an intel-mac?

Author:  Xfennec [ Thu Aug 31, 2006 4:54 pm ]
Post subject: 

"Intel-Mac" means nothing for me...

- Linux on x86 Mac ? Should be OK right now.
- x86 OSX ? OSX is not a supported platform for Raydium, because we don't have any maintainer for this OS.

Author:  Carnaby [ Thu Aug 31, 2006 10:02 pm ]
Post subject: 

Linux x86 (native) and Windows XP/Vista (with Boot Camp) can be both installed on a x86 Mac.

If you don't want to create a dedicated partition on your hard disk you can use linux live cd (like knoppix) and launch maniadrive from external storage (usb key...).

I bought my first Mac (MacBook) just since a few days but maybe when I'm more familiar with it I can try to do a MacOs port of Maniadrive (probably not a native port but try something with Fink or Darwin Port.

Author:  basti [ Thu Aug 31, 2006 10:37 pm ]
Post subject: 

i tried to get it working, but i had to stop when it asks me for opengl-devel packages...
fink didn't helped me ;)

and i don't want to run windows or linux on my mac... =)

Author:  Guest [ Sat Sep 02, 2006 11:09 am ]
Post subject: 

It asks for opengl-devel packages because it try to load <GL/***.h> but these headers are not avalaible on MacOS. MacOs include <OpenGL/***.h> but you can't use it because it don't include X11 specific functions (except if you want to rewrite code for making a native port).

I made some unsuccessful attempts this morning but I think the easiest way is to compile using MacOS X11 which contain all required files. In addition you need to install Glew (avalaible on Fink) and probably a few other things.

Author:  Carnaby [ Wed Sep 06, 2006 4:40 pm ]
Post subject: 

Oooops I forgot to login when i made previous post.

I made some fix and now ./configure stop to "testing glew" but i don't understand the error.
./configure return:
Code:
* Testing GLEW..../configure: line 335: 508 Bus error                                         ./configure.bin>>configure.log

and nothing in "Testing GLEW" part of configure.log.

Summary of my method
- install X11 (MacOS X cd version)
- install darwinport version of glew: http://glew.darwinports.com/
- fix compiling environnement (here is my modified configure file)

Author:  Xfennec [ Thu Sep 07, 2006 10:11 am ]
Post subject: 

Can you paste the end of the configure.log file after running the ./configure ?

Author:  Carnaby [ Thu Sep 07, 2006 11:45 am ]
Post subject: 

Code:
   Testing OpenGL
   ====================

   Testing GLU
   ====================

   Testing GL/GLU hardware support
   ====================
/usr/bin/ld: warning multiple definitions of symbol _glPointParameteri
/System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libGL.dylib(gll_api.o) definition of _glPointParameteri
/usr/X11R6/lib//libGL.dylib(dri_dispatch.o) definition of _glPointParameteri
/usr/bin/ld: warning multiple definitions of symbol _glPointParameteriv
/System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libGL.dylib(gll_api.o) definition of _glPointParameteriv
/usr/X11R6/lib//libGL.dylib(dri_dispatch.o) definition of _glPointParameteriv
no Xinerama support. See config.h for HAVE_XINERAMA symbolFound 320x240 with 24 bpp color and 24 bits zbuffer (stencil is 1)
   Testing GLEW
   ====================


"Testing Glew" part is empty :-/

Author:  Xfennec [ Thu Sep 07, 2006 3:54 pm ]
Post subject: 

And when you run the "./configure.bin" by hand ? (this file should be created by "configure" just before your "bus error")

Author:  Carnaby [ Thu Sep 07, 2006 7:45 pm ]
Post subject: 

Bon j'ai la flemme de faire celui ci en anglais donc comme il comporte pas d'infos cruciale je post en français ;-)

Alors je relance mon ./configure

Code:
* Testing GLEW..../configure: line 335:  6202 Bus error               ./configure.bin >>configure.log
 run: failed
   You must install libglew devel package

Comme d'habitude erreur de bus (note le numéro du bus change à chaque essai mais j'imagine que c'est normal).
Le fichier configure.bin est effectivement créer (note faut ruser pour le récupérer sinon le configure le réefface aussi sec sans laisser de trace) mais quand je le lance tout ce qu'il me retourne c'est
Code:
$ ./configure.bin.old
Bus error

Pas beaucoup plus explicite que les message précédent.
Peut être que le portage de glew est pas super fiable, faudrait voir si il pose des problèmes avec d'autre projet l'incluant dans leur dépendance.

Author:  Xfennec [ Fri Sep 08, 2006 10:31 am ]
Post subject: 

C'est peut être le test effectué notre configure qui est trop "brut". Je regarde ça de plus près.

Author:  Xfennec [ Thu Sep 14, 2006 9:33 pm ]
Post subject: 

Pardon d'avoir un peu oublié ce thread !

Essaye en modifiant la ligne
Code:
int main(void) { glewInit(); return 0; }
de facon a enlever le glewInit(); (pour qu'il ne reste que le return 0; donc)

Author:  Carnaby [ Thu Sep 14, 2006 11:51 pm ]
Post subject: 

Sans le glewinit() ça passe (on verra ce que ça donne par la suite).

Maintenant je bloque sur OpenAL, le port est dispo sur opendarwin mais pour cause de serveur succeptible et de connection bas débit je peux pas le choper aujourd'hui.
Ca attendra que je retrouve mon petit chez moi et ma grosse connec 30Mb. Il va moins faire le fière ce serveur qui me jette à cause de ma mauvaise connection :evil: .

Par contre OpenAL c'est le 1.0 et même pas le 1.1 qui est dispo, comme le message du configure fait référence a la version CVS j'ai un sérieux doute tout d'un coup.

La suite au prochaine épisode.

Author:  pov [ Tue Dec 12, 2006 7:57 pm ]
Post subject: 

Salut,

Des news concernant l'avancement de ce projet ? Je viens de tomber dessus un peu par hasard, un peu en cherchant autre chose, et ça m'a l'air très très interessant si ça veut bien marcher...

Author:  Xfennec [ Tue Dec 12, 2006 9:05 pm ]
Post subject: 

Si tu parles bien d'un portage MacOS X x86 de Raydium/ManiaDrive, je n'ai pas connaissance de nouvelles informations. Ce sujet est régulièrement reporté faute de main d'oeuvre sous cette plateforme :)

Page 1 of 2 All times are UTC
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/