Raydium 3D Game Engine

Official forum for everything about Raydium, ManiaDrive, MeMak, ...
It is currently Sun Feb 17, 2019 2:40 pm

All times are UTC




Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: no sound.
PostPosted: Wed Nov 08, 2006 6:06 pm 
Offline

Joined: Tue Nov 07, 2006 6:32 pm
Posts: 8
hi xfennec. am back again. i finally got the game and it runs great. love it. great game u guys. but have a l'il problem. i'm getting absolutely no sound in the game. am using an ensoniq audioPCI 128 bit card from creative labs. the card is detected and am having no problems with sound when not running the game. wat could be happening? thanks.


Top
 Profile  
 
 Post subject:
PostPosted: Wed Nov 08, 2006 7:44 pm 
Offline
User avatar

Joined: Thu Sep 29, 2005 2:59 pm
Posts: 828
i saw your output in the other thread and you have this line:
Code:
open /dev/[sound/]dsp: Device or resource busy
Raydium: ERROR: Cannot open Sound System

So you can check if you have such device created
Either /dev/dsp or /dev/sound/dsp.
Maybe your distro have changed the name of the device...


Top
 Profile  
 
 Post subject:
PostPosted: Wed Nov 08, 2006 8:02 pm 
Offline
User avatar

Joined: Sun Mar 16, 2003 2:53 am
Posts: 2590
Location: gnniiiii (Scrat)
Your sound card is already used by something else, it seems. KDE or Gnome used to do so, with some installations ...
Try to detect which app is using your dsp, with the following command (with root account) :
Code:
fuser -v /dev/dsp

If this command returns something, try to close/kill it ! ;)


Top
 Profile  
 
PostPosted: Thu Nov 09, 2006 3:32 am 
Offline

Joined: Tue Nov 07, 2006 6:32 pm
Posts: 8
hi guys, thanks for responding. i copied the output its giving this time with regards to sound. its different from earlier. pasted it below (only pasted the lines that read sound in them. left the game at the menu screen for around 10 mins):
Raydium: sound: Buffer creation successfull
Raydium: sound: OK, using 'default device'
Raydium: sound: end of file reached
Raydium: Now playing mania_music/08-Nowhere to go-The Napoleon Blown Aparts.ogg ...
Raydium: sound: ERROR : setting listener position :40961
Raydium: sound: end of file reached
Raydium: Now playing mania_music/revengeofyesterday.ogg ...
Raydium: sound: ERROR : setting listener position :40961
Raydium: timecall: warning: time modulo detected: workarounding
Raydium: sound: ov_read error
Raydium: sound: end of file reached
Raydium: Now playing mania_music/07-Mine tonite-Rocket City Riot.ogg ...
Raydium: sound: ERROR : setting listener position :40961
Raydium: sound: end of file reached
Raydium: Now playing mania_music/Zen_Ace_Ten_-_Superstar_Destroyer.ogg ...
Raydium: sound: ERROR : setting listener position :40961


before launching the game fuser doesn't return anything. after launching the game, the sound device is wholly owned by mania drive.


Top
 Profile  
 
 Post subject:
PostPosted: Thu Nov 09, 2006 10:03 am 
Offline
User avatar

Joined: Sun Mar 16, 2003 2:53 am
Posts: 2590
Location: gnniiiii (Scrat)
Nothing wrong here.
You have no more the error "open /dev/[sound/]dsp: Device or resource busy " ? Why ? Do you changed something ?
Other games have sound ?


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group