Raydium 3D Game Engine

Official forum for everything about Raydium, ManiaDrive, MeMak, ...
It is currently Tue Dec 12, 2017 6:14 am

All times are UTC




Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Tue Feb 09, 2010 2:35 am 
Offline
User avatar

Joined: Fri Apr 04, 2008 6:29 am
Posts: 7
Hello,

While the ./configure process, raydium downloads and compiles ODE and PHP (maybe more, I'm not done with php yet). This confuses me greatly. I have these packages installed, why does raydium not link to them instead?

Best regards


Last edited by qubodup on Tue Feb 09, 2010 11:09 pm, edited 1 time in total.

Top
 Profile  
 
PostPosted: Tue Feb 09, 2010 5:04 am 
Offline

Joined: Thu Oct 09, 2008 5:49 pm
Posts: 69
Hi.

(I'm unable to give an 'official' answer, someone else can help you more.. but:)

Raydium (I believe) needs a specific ODE version to be 'stable' (I think)

and I know Raydium allows for Rayphp (php scripting in your game) and I think it has to rebuild PHP no matter what, to allow for rayphp functions to work properly.


Again, I could be very wrong on the subject.

Good luck!


Top
 Profile  
 
PostPosted: Tue Feb 09, 2010 12:23 pm 
Offline
User avatar

Joined: Sun Mar 16, 2003 2:53 am
Posts: 2590
Location: gnniiiii (Scrat)
This question is quite common, there's probably some other posts somewhere in the forum, but I can't remember where.

Following powerpup118's answer, it's important for Raydium to have a consistent behavior for physics over the various platforms. It means a specific and "tested" release of ODE, with single precision. Most Linux distributions are providing unsuitable release of ODE (double precision, older/newer release) that can't be used "officially" for Raydium.

For instance, ManiaDrive is build around physics, so every single change in ODE may change the physics of the game, which is unacceptable for a game where players can compare scores online ...

It's the same story for PHP, where the "libphp" itself is not released everywhere (Debian, a few years ago at least, were not providing this package, only "static" release of php-cli, mod-php, ...) and with incompatible release and/or compilation options.

If it's a real trouble for you, it's quite easy to change the Makefile to make it using your own libraries. It seems to be how Fedora deals with Raydium and ManiaDrive for official packets, for instance. But I'll definitely not support something like that ;)


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group