Raydium 3D Game Engine

Official forum for everything about Raydium, ManiaDrive, MeMak, ...
It is currently Wed Dec 13, 2017 5:07 am

All times are UTC




Post new topic Reply to topic  [ 6 posts ] 
Author Message
PostPosted: Tue Jan 25, 2011 3:00 pm 
Offline

Joined: Mon Jun 21, 2010 10:31 am
Posts: 12
Hi there,

I have some strange effects with new or changed Texture-Files in .tga-format.

Using Paint Shop Pro I have created new files and save them in the specified format, but the effect is that the colors seems to be rotated in the RGB-Room.
In any Picture-Viewer or even in Blender all colors are correct, but in game blue is changed into green, yellow changes to purple, ....

I have no idea why.

So did someone know this problem? And how can I solve it?


greetz matzze

P.S.: I saved them uncompressed and in 24-Bit


Top
 Profile  
 
PostPosted: Wed Jan 26, 2011 5:56 pm 
Offline

Joined: Sun Oct 09, 2005 10:46 pm
Posts: 759
Hello,

The file use perhaps a different RGB scheme. I don't remenber à flag in tga header to handle this.
Can you post the file and a sample .tri i'll test and perhapse correct raydium tga loader.

Have a nice day.
Ouille.


Top
 Profile  
 
PostPosted: Wed Jan 26, 2011 10:18 pm 
Offline

Joined: Mon Jun 21, 2010 10:31 am
Posts: 12
Hi,

yes they did. And I solved it just saving the files again with GIMP 2. The header changed in a few bits, I think it was a color map problem. Seems like raydium didn't interpret this information...
I'll never use PSP again :D

greetz matzze


Top
 Profile  
 
PostPosted: Thu Jan 27, 2011 8:39 am 
Offline

Joined: Sun Oct 09, 2005 10:46 pm
Posts: 759
Hello,

can you post (attach) both texture (or a sample with the same problem), i'll try to correct tga loader.

Have a nice day.
Ouille


Top
 Profile  
 
PostPosted: Fri Jan 28, 2011 1:55 pm 
Offline

Joined: Mon Jun 21, 2010 10:31 am
Posts: 12
Hi ouille,

here are 2 Textures, one saved with Paint Shop Pro. In Hex-Editor you can see that the headers are not the same.
The blue will become green in maniadrive if you use the car41_psp.tga.
The car41.tga is the same file just saved again with GIMP.
They work on the clio_sp.tri model!


have a nice day! :wink:

greetz matzze


Attachments:
parts.rar [246.92 KiB]
Downloaded 227 times
Top
 Profile  
 
PostPosted: Mon Feb 07, 2011 6:18 pm 
Offline

Joined: Sun Oct 09, 2005 10:46 pm
Posts: 759
Hello,

Thank you, it's now corrected in rev 1048.

Psp seem's to add on byte of index after header, an then colors slide from rgb to gbr . There is no RGB scheme in tga header.

Test and report problems.

For information, you _psp texture make blender crash !!!!

Have a nice day.
Ouille


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group