Raydium 3D Game Engine

Official forum for everything about Raydium, ManiaDrive, MeMak, ...
It is currently Thu Nov 26, 2020 7:25 am

All times are UTC




Post new topic Reply to topic  [ 7 posts ] 
Author Message
PostPosted: Thu Jun 01, 2006 10:05 pm 
Offline
User avatar

Joined: Thu Sep 29, 2005 2:59 pm
Posts: 828
Compiling raydium (the svn version) i get the next output:

Code:
* Installing ODE...
   ODE install detected. If you want to reinstall, add --force-ode-install.
* Installing PHP5 ...
   Testing 'bison' ...
   Testing 'libcurl' ...
   Testing 'libxml2' ...
   Downloading latest PHP5 ...
--23:55:35--  http://snaps.php.net/php5.2-latest.tar.gz
           => `raydium/php-latest.tar.gz'
Resolviendo snaps.php.net... 128.39.198.38
Connecting to snaps.php.net|128.39.198.38|:80... conectado.
Petición HTTP enviada, esperando respuesta... 200 OK
Longitud: 7,708,191 (7.4M) [application/x-tar]

100%[====================================>] 7,708,191    530.64K/s    ETA 00:00

23:55:51 (484.92 KB/s) - `raydium/php-latest.tar.gz' saved [7708191/7708191]

   Uncompressing ...
   Renaming raydium/php5.2-200606012030 to raydium/php/ ...
   Configuring PHP ...
   PHP configure failed (missing libs ?). See configure.log

and in the config.log has
Code:
Configuring PHP
===============
creating cache ./config.cache
checking for Cygwin environment... no
checking for mingw32 environment... no
checking for egrep... grep -E
checking for a sed that does not truncate output... /bin/sed
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking for gcc... gcc
checking whether the C compiler (gcc  ) works... yes
checking whether the C compiler (gcc  ) is a cross-compiler... no
checking whether we are using GNU C... yes
checking whether gcc accepts -g... yes
checking whether gcc and cc understand -c and -o together... yes
checking how to run the C preprocessor... gcc -E
checking for AIX... no
checking whether ln -s works... yes
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking for re2c... no
configure: warning: You will need re2c 0.9.11 or later if you want to regenerate PHP parsers.
checking for gawk... gawk
checking for bison... bison -y
checking for bison version... 2.0 (ok)
checking for flex... flex
checking for yywrap in -lfl... yes
checking lex output file root... lex.yy
checking whether yytext is a pointer... yes
checking for working const... yes
checking for flex version... invalid
configure: error: flex versions supported for regeneration of the Zend/PHP parsers: 2.5.4  (found: 2.5.31).

The reason is that flex version in ubuntu breezy is 2.5.31, not 2.5.40. So now raydium can't be compiled in ubuntu breezy ...


Top
 Profile  
 
 Post subject:
PostPosted: Thu Jun 01, 2006 10:11 pm 
Offline
User avatar

Joined: Thu Sep 29, 2005 2:59 pm
Posts: 828
re2c also is giving version problems
Code:
checking for re2c version... invalid
configure: warning: You will need re2c 0.9.11 or later if you want to regenerate PHP parsers.

The ubuntu version is 0.9.1-6build1


Top
 Profile  
 
 Post subject:
PostPosted: Fri Jun 02, 2006 6:42 am 
Offline
User avatar

Joined: Fri May 19, 2006 4:28 pm
Posts: 39
You should be able to update these packages....

_________________
Charly


Top
 Profile  
 
 Post subject:
PostPosted: Fri Jun 02, 2006 7:09 am 
Offline
User avatar

Joined: Sun May 28, 2006 7:17 pm
Posts: 12
Location: USA
Is there a package called flex-old in ubuntu? I'm on debian and needed to grab that, mine is version 2.5.4a-7. The normal package flex in debian is 2.5.33-4. I'm not that familiar with flex so I don't know what is going on with the version numbers.

If you do have the flex-old package, give it a try. If not, you could try the debian package too here:

http://ftp.debian.org/debian/pool/main/f/flex-old/flex-old_2.5.4a-7_i386.deb

Just incase you're not sure how to install debs outside of apt-get/synaptic, here's what you can do. I can't quite remember if ubuntu by default uses sudo. I think it does, so in ubuntu you can do this in the console:

Code:
sudo dpkg -i flex-old/flex-old_2.5.4a-7_i386.deb


Top
 Profile  
 
 Post subject:
PostPosted: Fri Jun 02, 2006 8:40 am 
Offline
User avatar

Joined: Thu Sep 29, 2005 2:59 pm
Posts: 828
thank Mike, that "old" version of flex is newer than the newer ¿?
And it worked.

Re2c looks like no a vital dependency, as i get to compile full raydium.

cghislai, i can not upload version as i desire. I'm collaborator in a few projects and my distro should be as regular as possible, with no depenccencies problems.

Also i have the opinion that Raydium should maintain its minimun requirements to execute and to compile with the lower versions possible. In fact the inclusion of OpenAL1 in Raydium is giving problems, like i have no music in ubuntu...


Top
 Profile  
 
 Post subject:
PostPosted: Sat Jun 03, 2006 11:17 am 
Offline
User avatar

Joined: Sun Mar 16, 2003 2:53 am
Posts: 2591
Location: gnniiiii (Scrat)
We've already encountered this problem with flex. It seems that there was a major rewrite of flex, switching from 2.5.4 to 2.5.31 (adding reentrant code support) and that both version are not compatible at all. Note that 2.5.31 is newer than 2.5.4 ;)
It seems that this bug was corrected : http://bugs.php.net/bug.php?id=37413 so we've just to wait for the next PHP release.

About OpenAL (wich is definitely pain in the ...), we must found why your version does not play music. What version of OpenAL your distro provides ?


Top
 Profile  
 
 Post subject:
PostPosted: Sat Jun 03, 2006 2:57 pm 
Offline
User avatar

Joined: Thu Sep 29, 2005 2:59 pm
Posts: 828
About openAL my versions are:

libopenal0 0.2004090900-1.1build1
libopenal-dev 0.2004090900-1.1build1

They are upgraded to the newer version in ubuntu breezy.
Xfennek, i think that we already talked about this problem some time ago, and no solution got achieved apart of wait until ubuntu reach the new versions of openAL.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group