Raydium 3D Game Engine

Official forum for everything about Raydium, ManiaDrive, MeMak, ...
It is currently Wed Oct 23, 2019 12:47 am

All times are UTC




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: Bug viewports
PostPosted: Thu Oct 12, 2006 7:35 pm 
Offline

Joined: Sun Oct 09, 2005 10:46 pm
Posts: 759
Bonjour,

J'essaye de corriger le bug du viewport en affichage debug.
Le fil de fer qui s'affiche dans la vue principale correspond a la vue du viewport et non a celle de la vue principale.

Je n'ai malheureusement pas trouvé.
Cependant je voulais soumettre ceci:

La première suspension est affichée correctement dans le debug elle est bien dessinée a la position de la fenetre principale.

Le fil de fer apparait erroné à la 8ieme activation de la fenetre secondaire, après donc que 8 images aient etées crées. Il me semble avoir lu quelque part que la pile opengl etait de 8 niveau. Y aurait'il un rapport ?

Une idée d'une direction dans laquelle chercher ?

A+
Jacques.


Top
 Profile  
 
 Post subject:
PostPosted: Fri Oct 13, 2006 11:05 am 
Offline
User avatar

Joined: Sun Mar 16, 2003 2:53 am
Posts: 2590
Location: gnniiiii (Scrat)
Bien vu pour ton commit 447 !

(désolé, j'ai peu de temps à consacrer à Raydium en ce moment)


Top
 Profile  
 
 Post subject: Opengl
PostPosted: Fri Oct 13, 2006 11:14 am 
Offline

Joined: Sun Oct 09, 2005 10:46 pm
Posts: 759
Bonjour,

Effectivement j'ai fini par trouver.
Pour la suite tu peux peut etre m'aider:

Le dessin des AABB dans le viewport ou dans la fenetre principale se passe bien, ce n'est pas le cas pour le draw_debug.
Je premier objet n'est pas dessiné dans l'espace camera du viewport, mais dans l'espace de la fenetre principale.

J'ai essayé de comparer les codes des AABB et DEBUG, peux tu y jeter un oeil, tu risque de voir assez facilement ce qui manque dans la partie debug.
La partie initiale est identique par contre le dessin des objet ne se fait pas de la meme facon.

A+
Jacques
P.S.: Un manip raydium tourne ici pour la fête de la science sans planter depuis 1 jour et demi. Avec le logo qui tourne en bas. Bientot la celebritée ;o)


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group