Raydium 3D Game Engine

Official forum for everything about Raydium, ManiaDrive, MeMak, ...
It is currently Wed Oct 01, 2014 8:10 am

All times are UTC




Post new topic Reply to topic  [ 11 posts ] 
Author Message
 Post subject: Segmentation fault
PostPosted: Fri Aug 18, 2006 5:49 pm 
I have the following problem:

Raydium: Raydium 3D Game Engine
Raydium: version 0.704
Raydium: command line args: OK
Raydium: chdir to './game/': OK
Raydium: using '/root/.mania_drive' as home dir
Raydium: Requesting 800x600:32 mode
Raydium: no Xinerama on this display
Raydium: Found 1024x768 with 24 bpp color and 24 bits zbuffer (stencil is 1)
Raydium: using RADEON 9250/9200 Series DDR Generic, from ATI Technologies Inc. (version 1.3.1091 (X4.3.0-8.27.6))
Raydium: Signal Handlers: OK
Raydium: OpenGL extensions: OK
Raydium: Platform "4xfloat" vector size is: 16 byte(s) long
Raydium: OpenGL implementation maximum texture size: 2048x2048
Raydium: OpenGL hardware providing 6 texture unit(s)
Raydium: vertex arrays memory: OK
Raydium: path: OK
Raydium: keyboard: OK
Raydium: mouse: OK
Raydium: joy: FAILED (cannot open /dev/js0 and /dev/input/js0)
Raydium: sound: Buffer creation successfull
Raydium: sound: OK, using 'default device'
Raydium: PHP support: OK
Raydium: atexit functions: OK
Raydium: lights: OK
Raydium: fog: OK
Raydium: objects: OK
Raydium: network: OK
Raydium: timer: detection: 1 iterations: diff: 1 steps (1000000/sec)
Raydium: timecall: method accuracy = 0.001 ms (999999.94 Hz)
Raydium: timecall: Using basic gettimeofday() method
Raydium: timecall: OK (999999 Hz)
Raydium: timecall: softcall 0: 1 Hz (1000000 clocks interval)
Raydium: particle: OK
Raydium: gui: OK
Raydium: video (live): OK
Raydium: shadow: OK
Raydium: HDR: OK
Raydium: shaders: FAILED (GLSL 1.0 not found)
Raydium: webserver: OK
Raydium: Raydium engine reseted to original state
Raydium: timecall: callback 1: 400 Hz (2500 clocks interval)
Raydium: physics: ODE Net: 10 element(s)/packet
Raydium: physics: OK
Raydium: RegAPI: OK
Raydium: Engine is now ready.
-----------------------------------------------------------
Raydium: sound: Tried to set negative or 0 Pitch , clipped to 0.1
Raydium: Texture num 1 (BOXfront.tga) loaded: 512x512, 3 Bpp (b0 lm0 hdr0)
Raydium: Texture num 2 (BOXback.tga) loaded: 512x512, 3 Bpp (b0 lm0 hdr0)
Raydium: Texture num 3 (BOXleft.tga) loaded: 512x512, 3 Bpp (b0 lm0 hdr0)
Raydium: Texture num 4 (BOXright.tga) loaded: 512x512, 3 Bpp (b0 lm0 hdr0)
Raydium: Texture num 5 (BOXbottom.tga) loaded: 512x512, 3 Bpp (b0 lm0 hdr0)
Raydium: Texture num 6 (BOXtop.tga) loaded: 512x512, 3 Bpp (b0 lm0 hdr0)
Raydium: Texture num 7 (theme-maniadrive.tga) loaded: 256x256, 4 Bpp (b1 lm0 hdr0)
Raydium: Texture num 8 (font3.tga) loaded: 512x512, 1 Bpp (b1 lm0 hdr0)
Raydium: timecall: softcall 2: 1 Hz (1000000 clocks interval)
Raydium: Changing game state to 1
Raydium: timecall: WARNING ! 0 Hz callback (num 1)
Segmentation fault

I use Gentoo with 2.6.17 kernel

Please help me if you can


Top
  
 
 Post subject:
PostPosted: Fri Aug 18, 2006 8:33 pm 
Offline
User avatar

Joined: Sun Mar 16, 2003 2:53 am
Posts: 2577
Location: gnniiiii (Scrat)
Well ... It seems related to 3D, but it's not clear what's exactly the problem.

Try this:
- enter the "game" directory
- use: "gdb ./mania_drive.static" (you must install GDB if not already done)
- "run"
[it will run the game ... and crash]
- "bt"

And paste the resulting backtrace here. It will probably help us a lot.
Have you ever launched any other "big" 3D application on this system ? (Quake 3, ET, ...)


Top
 Profile  
 
 Post subject: gdb
PostPosted: Sat Aug 19, 2006 1:51 am 
I just get a black screen, and i can't switch back to desktop, and i can't close the game (alt+f4).

is there any parameter to run game in window?

Yes i played 3d games. I have opengl support. I have Neverwinter Nights Platinum, and it works great.


Top
  
 
 Post subject:
PostPosted: Sat Aug 19, 2006 12:55 pm 
Offline
User avatar

Joined: Sun Mar 16, 2003 2:53 am
Posts: 2577
Location: gnniiiii (Scrat)
instead of "run" in gdb, use "run --window", it should help.


Top
 Profile  
 
 Post subject:
PostPosted: Sun Aug 20, 2006 12:05 am 
Hello,

I am having the same problem. Since the previous poster hasn't responded yet, I'll supply the output. I hope this will help. I've been playing the older version, it works with no problems, but I'd really like to get the new version working. Thanks for the help!

Code:
(gdb) run --window
Starting program: /media/sda1/downloads/web/ManiaDrive-1.1-linux-i386/game/mania_drive.static --window
[Thread debugging using libthread_db enabled]
[New Thread -1221478144 (LWP 5635)]
Raydium: Raydium 3D Game Engine
Raydium: version 0.704
Raydium: command line args: OK
Raydium: chdir to '/media/sda1/downloads/web/ManiaDrive-1.1-linux-i386/game/': OK
Raydium: using '/home/doughsay/.mania_drive' as home dir
Raydium: Requesting 800x600:32 mode
Raydium: no Xinerama on this display
Raydium: (my)glut: WARNING: This is an *INDIRECT* rendering context.
Raydium: Found 800x600 with 24 bpp color and 24 bits zbuffer (stencil is 1)
Raydium: using GeForce4 Ti 4200/AGP/SSE2/3DNOW!, from NVIDIA Corporation (version 1.2 (1.5.6 NVIDIA 87.62))
Raydium: Signal Handlers: OK
Raydium: OpenGL extensions: OK
Raydium: Platform "4xfloat" vector size is: 16 byte(s) long
Raydium: OpenGL implementation maximum texture size: 4096x4096
Raydium: OpenGL hardware providing 4 texture unit(s)
Raydium: vertex arrays memory: OK
Raydium: path: OK
Raydium: keyboard: OK
Raydium: mouse: OK
Raydium: /dev/input/event0: cannot open (rw), no Force Feedback.
Raydium: joy: FAILED (cannot open /dev/js0 and /dev/input/js0)
[New Thread -1352660048 (LWP 5638)]
Raydium: sound: Buffer creation successfull
Raydium: sound: OK, using 'default device'
Raydium: PHP support: OK
Raydium: atexit functions: OK
Raydium: lights: OK
Raydium: fog: OK
Raydium: objects: OK
Raydium: network: OK
Raydium: timer: detection: 1 iterations: diff: 2 steps (1000000/sec)
Raydium: timecall: method accuracy = 0.002 ms (499999.97 Hz)
Raydium: timecall: Using basic gettimeofday() method
Raydium: timecall: OK (499999 Hz)
Raydium: timecall: softcall 0: 1 Hz (1000000 clocks interval)
Raydium: particle: OK
Raydium: gui: OK
Raydium: video (live): OK
Raydium: shadow: OK
Raydium: HDR: OK
Raydium: shaders: FAILED (GLSL 1.0 not found)
Raydium: webserver: OK
Raydium: Raydium engine reseted to original state
Raydium: timecall: callback 1: 400 Hz (2500 clocks interval)
Raydium: physics: ODE Net: 10 element(s)/packet
Raydium: physics: OK
Raydium: RegAPI: OK
Raydium: Engine is now ready.
         -----------------------------------------------------------
Raydium: sound: Tried to set negative or 0 Pitch , clipped to 0.1
Raydium: Texture num 1 (BOXfront.tga) loaded: 512x512, 3 Bpp (b0 lm0 hdr0)
Raydium: Texture num 2 (BOXback.tga) loaded: 512x512, 3 Bpp (b0 lm0 hdr0)
Raydium: Texture num 3 (BOXleft.tga) loaded: 512x512, 3 Bpp (b0 lm0 hdr0)
Raydium: Texture num 4 (BOXright.tga) loaded: 512x512, 3 Bpp (b0 lm0 hdr0)
Raydium: Texture num 5 (BOXbottom.tga) loaded: 512x512, 3 Bpp (b0 lm0 hdr0)
Raydium: Texture num 6 (BOXtop.tga) loaded: 512x512, 3 Bpp (b0 lm0 hdr0)
Raydium: Texture num 7 (theme-maniadrive.tga) loaded: 256x256, 4 Bpp (b1 lm0 hdr0)
Raydium: Texture num 8 (font3.tga) loaded: 512x512, 1 Bpp (b1 lm0 hdr0)
Raydium: timecall: softcall 2: 1 Hz (1000000 clocks interval)
Raydium: Changing game state to 1
Raydium: timecall: WARNING ! 0 Hz callback (num 1)

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1221478144 (LWP 5635)]
0x00000000 in ?? ()
(gdb) bt
#0  0x00000000 in ?? ()
#1  0x080627a2 in raydium_shader_current (shader=-1) at shader.c:291
#2  0x08059bf3 in raydium_rendering_prepare_texture_unit (tu=33984, tex=1)
    at render.c:147
#3  0x08059ec8 in raydium_rendering_internal_prepare_texture_render (tex=1)
    at render.c:222
#4  0x0806d131 in raydium_sky_box_render (x=0.100000001, y=0.100000001, z=0)
    at sky.c:51
#5  0x08071158 in raydium_camera_internal (x=0.100000001, y=0.100000001, z=0)
    at camera.c:108
#6  0x08071355 in raydium_camera_look_at (x=0.100000001, y=0.100000001, z=0,
    x_to=0, y_to=1, z_to=0) at camera.c:154
#7  0x08091367 in display () at mania_drive.c:2176
#8  0x08053c84 in glutMainLoop () at myglut.c:59
#9  0x0805e80c in raydium_callback (loop=0x809103e) at callback.c:86
#10 0x08092708 in main (argc=2, argv=0xbfef1b54) at mania_drive.c:2599


Top
  
 
 Post subject:
PostPosted: Sun Aug 20, 2006 1:28 am 
Offline
User avatar

Joined: Sun Mar 16, 2003 2:53 am
Posts: 2577
Location: gnniiiii (Scrat)
OK, great ! Thanks a lot. I'll try to fix this ASAP and release MD 1.2. The problem seems related to shader support.


Top
 Profile  
 
 Post subject:
PostPosted: Sun Aug 20, 2006 2:19 am 
Thanks! This is a great game, keep it up.


Top
  
 
 Post subject:
PostPosted: Sun Aug 20, 2006 2:01 pm 
Offline
User avatar

Joined: Sun Mar 16, 2003 2:53 am
Posts: 2577
Location: gnniiiii (Scrat)
Is someone with this problem can try this "experimental" binary ?

http://ftp.cqfd-corp.org/mania_drive.static.gz

I ask you to paste here the full console output. Thanks a lot !


Top
 Profile  
 
 Post subject: Patch works
PostPosted: Sun Aug 20, 2006 7:45 pm 
Here's the output. Fix works! Great!
Keep up the good work :)

Starting program: /usr/games/ManiaDrive-1.1-linux-i386/game/mania_drive.static --window
[Thread debugging using libthread_db enabled]
[New Thread -1214244672 (LWP 14852)]
Raydium: Raydium 3D Game Engine
Raydium: version 0.704
Raydium: command line args: OK
Raydium: chdir to '/usr/games/ManiaDrive-1.1-linux-i386/game/': OK
Raydium: using '/root/.mania_drive' as home dir
Raydium: Requesting 800x600:32 mode
Raydium: no Xinerama on this display
Raydium: Found 800x600 with 24 bpp color and 24 bits zbuffer (stencil is 1)
Raydium: using RADEON 9250/9200 Series DDR Generic, from ATI Technologies Inc. (version 1.3.1091 (X4.3.0-8.27.6))
Raydium: Signal Handlers: OK
Raydium: OpenGL extensions: OK
Raydium: Platform "4xfloat" vector size is: 16 byte(s) long
Raydium: OpenGL implementation maximum texture size: 2048x2048
Raydium: OpenGL hardware providing 6 texture unit(s)
Raydium: vertex arrays memory: OK
Raydium: path: OK
Raydium: keyboard: OK
Raydium: mouse: OK
Raydium: joy: FAILED (cannot open /dev/js0 and /dev/input/js0)
[New Thread -1504404560 (LWP 14855)]
Raydium: sound: Buffer creation successfull
Raydium: sound: OK, using 'default device'
Raydium: PHP support: OK
Raydium: atexit functions: OK
Raydium: lights: OK
Raydium: fog: OK
Raydium: objects: OK
Raydium: network: OK
Raydium: timer: detection: 1 iterations: diff: 1 steps (1000000/sec)
Raydium: timecall: method accuracy = 0.001 ms (999999.94 Hz)
Raydium: timecall: Using basic gettimeofday() method
Raydium: timecall: OK (999999 Hz)
Raydium: timecall: softcall 0: 1 Hz (1000000 clocks interval)
Raydium: particle: OK
Raydium: gui: OK
Raydium: video (live): OK
Raydium: shadow: OK
Raydium: HDR: OK
Raydium: shaders: FAILED (GLSL 1.0 not found)
Raydium: webserver: OK
Raydium: Raydium engine reseted to original state
Raydium: timecall: callback 1: 400 Hz (2500 clocks interval)
Raydium: physics: ODE Net: 10 element(s)/packet
Raydium: physics: OK
Raydium: RegAPI: OK
Raydium: Engine is now ready.
-----------------------------------------------------------
Raydium: sound: Tried to set negative or 0 Pitch , clipped to 0.1
Raydium: Texture num 1 (BOXfront.tga) loaded: 512x512, 3 Bpp (b0 lm0 hdr0)
Raydium: Texture num 2 (BOXback.tga) loaded: 512x512, 3 Bpp (b0 lm0 hdr0)
Raydium: Texture num 3 (BOXleft.tga) loaded: 512x512, 3 Bpp (b0 lm0 hdr0)
Raydium: Texture num 4 (BOXright.tga) loaded: 512x512, 3 Bpp (b0 lm0 hdr0)
Raydium: Texture num 5 (BOXbottom.tga) loaded: 512x512, 3 Bpp (b0 lm0 hdr0)
Raydium: Texture num 6 (BOXtop.tga) loaded: 512x512, 3 Bpp (b0 lm0 hdr0)
Raydium: Texture num 7 (theme-maniadrive.tga) loaded: 256x256, 4 Bpp (b1 lm0 hdr0)
Raydium: Texture num 8 (font3.tga) loaded: 512x512, 1 Bpp (b1 lm0 hdr0)
Raydium: timecall: softcall 2: 1 Hz (1000000 clocks interval)
Raydium: Changing game state to 1
Raydium: timecall: WARNING ! 0 Hz callback (num 1)
Raydium: Texture num 9 (video) FAKED: 256x256, 3 Bpp (b0 lm0 hdr0)
Raydium: live: texture 'video' created
Raydium: video: mania_menu_v1.jpgs (0) as live texture video (0), 256x256 20.00 fps (703 frames)
Raydium: Texture num 10 (BOXmania_cursor.tga) loaded: 32x32, 4 Bpp (b1 lm0 hdr0)Raydium: ODE: Error: Cannot delete object: invalid name or index
Raydium: Texture num 11 (mania_logo2.tga) loaded: 512x512, 3 Bpp (b0 lm0 hdr0)
Raydium: Texture num 12 (BOXmania_music_popup.tga) loaded: 512x128, 4 Bpp (b1 lm0 hdr0)
Raydium: Texture num 13 (font2.tga) loaded: 512x512, 1 Bpp (b1 lm0 hdr0)
Raydium: Changing game state to 2
Raydium: timecall: callback 1: 400 Hz (2500 clocks interval)
Raydium: Internal buffers:
Raydium: -----------------
Raydium: Total of 0 vertex(s) loaded:
Raydium: Texture num 0: 0 vertex(s) - loaded as "dummy.null"
Raydium: Texture num 1: 0 vertex(s) - loaded as "BOXfront.tga"
Raydium: Texture num 2: 0 vertex(s) - loaded as "BOXback.tga"
Raydium: Texture num 3: 0 vertex(s) - loaded as "BOXleft.tga"
Raydium: Texture num 4: 0 vertex(s) - loaded as "BOXright.tga"
Raydium: Texture num 5: 0 vertex(s) - loaded as "BOXbottom.tga"
Raydium: Texture num 6: 0 vertex(s) - loaded as "BOXtop.tga"
Raydium: Texture num 7: 0 vertex(s) - loaded as "theme-maniadrive.tga"
Raydium: Texture num 8: 0 vertex(s) - loaded as "font3.tga"
Raydium: Texture num 9: 0 vertex(s) - loaded as "video"
Raydium: Texture num 10: 0 vertex(s) - loaded as "BOXmania_cursor.tga"
Raydium: Texture num 11: 0 vertex(s) - loaded as "mania_logo2.tga"
Raydium: Texture num 12: 0 vertex(s) - loaded as "BOXmania_music_popup.tga"
Raydium: Texture num 13: 0 vertex(s) - loaded as "font2.tga"
Raydium: Estimated total: 10.92 MB used for textures.
Raydium: Using 0 object(s):
Raydium: sound: Deleting sources
Raydium: sound: Deleting buffers
Raydium: sound: Releasing OpenAL
[Thread -1504404560 (zombie) exited]
Raydium: path: read: "/root/.mania_drive/data"
Raydium: path: write: "/root/.mania_drive/data"


Top
  
 
 Post subject:
PostPosted: Sun Aug 20, 2006 9:50 pm 
Offline
User avatar

Joined: Sun Mar 16, 2003 2:53 am
Posts: 2577
Location: gnniiiii (Scrat)
To all here: thanks a lot ! I'm preparing a new release with the fix. Should be OK tomorrow.


Top
 Profile  
 
 Post subject:
PostPosted: Mon Aug 21, 2006 1:17 am 
Yes, thanks a lot, the fix worked for me too. It seems you don't really need the output from me as well, but if you do need it let me know. Thanks for fixing it so quickly!


Top
  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 11 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group