Raydium 3D Game Engine

Official forum for everything about Raydium, ManiaDrive, MeMak, ...
It is currently Tue Apr 23, 2024 6:25 pm

All times are UTC

Post new topic Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Sat Jan 30, 2010 5:20 pm 

Joined: Sat Jan 30, 2010 5:16 pm
Posts: 1

I am using linux (ubuntu 8.04), and I have a problem: my USB steering wheel is not recognized in ManiaDrive. I tried the -- joydev option but it didn't work. Also, I'm not sure I'm using it correctly.
Here is the relevant part of the output of dmesg:
[ 6291.812832] input: GreenAsia Inc.    USB Joystick      as /devices/pci0000:00/0000:00:02.0/usb1/1-2/1-2:1.0/input/input11
[ 6291.844724] input,hidraw0: USB HID v1.10 Joystick [GreenAsia Inc.    USB Joystick     ] on usb-0000:00:02.0-2

Can you please tell me how should I run ManiaDrive to have support for my joystick?

Thanks a lot!

PostPosted: Mon Feb 01, 2010 10:15 pm 
User avatar

Joined: Sun Mar 16, 2003 2:53 am
Posts: 2591
Location: gnniiiii (Scrat)

You said you've tried the --joydev command line switch, but which device have you provided to this switch ?
You should have a look at /dev/input/js* so you could find you game controller and give it the the joydev option.

Another (important !) point is that currently, ManiaDrive does not allows the user to change controls (sadly). So if the mapping of your device is not correct by default (which is very likely), you won't be able to use your controller unless you start modifying the game's source code.

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC

Who is online

Users browsing this forum: No registered users and 53 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group